Register FAQ Search Today's Posts Mark Forums Read
Go Back   JazzJackrabbit Community Forums » Open Forums » General Jazz Jackrabbit Talk

IRC Identd error when connecting to servers.

DoomFrost

JCF Member

Joined: Sep 2005

Posts: 24

DoomFrost is doing well so far

Sep 13, 2005, 10:45 AM
DoomFrost is offline
Reply With Quote
IRC Identd error when connecting to servers.

It happened last night, I got disconnected by Quakenet and when I tried to re-connect it popped up saying I needed to install and enable Identd in order to use the server. I also have tried other servers to see if it was an isolated problem, but it wasn't as other various servers say the exact same thing. Thing is that some servers I've been able to connect to, while other servers I can't. I need to know what caused this problem, because yesterday I was fine but when it hit around 8:00-8:30PM (20:00-20:30 -5 EST), thats when the problems started.

I'm trying to look into many options as to why I'm getting the problem. I've tried searching Google, but I can't find what I'm looking for.

Anyways thanks for any help you can provide.
__________________

Last edited by DoomFrost; Sep 13, 2005 at 12:03 PM.
White Rabbit White Rabbit's Avatar

JCF Member

Joined: Aug 2001

Posts: 4,478

White Rabbit is doing well so far

Sep 13, 2005, 10:59 AM
White Rabbit is offline
Reply With Quote
Do you have mIrc? Just go to Tools->Options->Connect->Identd->Enable Identd
DoomFrost

JCF Member

Joined: Sep 2005

Posts: 24

DoomFrost is doing well so far

Sep 13, 2005, 11:59 AM
DoomFrost is offline
Reply With Quote
That's the problem White Rabbit, I do have it enabled.

I tried a system restore to see if that would help, but that didn't work at all so I reverted. I'm really stumped on this. Anyone know of any technical sites I can go to?

(Also I've been on Quake Net's FAQ as other countless FAQ's but none seem to make mention of this.)

EDIT: I've also tried using other IRC programs, but the same thing happens. I'm really not sure if it's the hardware firewall on the host computer or not thats causing the problems since it was fine yesterday when I connected.
__________________
Sonyk Sonyk's Avatar

JCF Member

Joined: Feb 2005

Posts: 2,409

Sonyk is doing well so far

Sep 13, 2005, 12:05 PM
Sonyk is offline
Reply With Quote
You could always try opening whatever port you have the identd server set to, if you haven't done so already
DoomFrost

JCF Member

Joined: Sep 2005

Posts: 24

DoomFrost is doing well so far

Sep 13, 2005, 12:08 PM
DoomFrost is offline
Reply With Quote
Quote:
Originally Posted by Sonyk
You could always try opening whatever port you have the identd server set to, if you haven't done so already
I've tried that on this computer already and no such luck. The host computer where I'm getting the internet access from doesn't have windows firewall enabled. So how would one open up ports on a hardware firewall?

EDIT: I may try reseting the router to see if that works...
__________________
Link Link's Avatar

Untitled

Joined: Apr 2001

Posts: 2,099

Link is doing well so far

Sep 13, 2005, 01:00 PM
Link is offline
Reply With Quote
Quakenet may not be letting you connect without an ident because they have had problems with abuse from your address or ISP. Idents allow multiple users from the same address to be uniquely identified by username, so bans can be more specific.

If you're using a router or gateway, you will have to forward port 113 to your computer. This process varies depending on your configuration. Also ensure that it is not being blocked by any firewalls.
__________________
With our extreme gelatinous apology,
We beg to inform your Imperial Majesty,
Unto whom be dominion and power and glory,
There still remains that strange precipitate
Which has the quality to resist
Our oldest and most trusted catalyst.
It is a substance we cannot cremate
By temperatures known to our Laboratory.

~ E.J. Pratt
 
DoomFrost

JCF Member

Joined: Sep 2005

Posts: 24

DoomFrost is doing well so far

Sep 13, 2005, 01:41 PM
DoomFrost is offline
Reply With Quote
Quote:
Originally Posted by Link
Quakenet may not be letting you connect without an ident because they have had problems with abuse from your address or ISP. Idents allow multiple users from the same address to be uniquely identified by username, so bans can be more specific.

If you're using a router or gateway, you will have to forward port 113 to your computer. This process varies depending on your configuration. Also ensure that it is not being blocked by any firewalls.
Well the firewall isn't enabled on the host computer. Well Windows firewall isn't enabled.
__________________
Link Link's Avatar

Untitled

Joined: Apr 2001

Posts: 2,099

Link is doing well so far

Sep 13, 2005, 03:03 PM
Link is offline
Reply With Quote
Your host computer (gateway) has to 'forward' network packets sent to port 113 to the computer on which you're using mIRC. While it may not be blocking them with its firewall, it doesn't know where they should go on your network.

Similar configuration is required to play JJ2 online. The following image may help you understand what's going on:



Think of the returning packets as the Quakenet ident request. When it hits the router (gateway/host computer), that computer doesn't know what to do and just drops the packet. The information in the article (click on the image) may help you forward ports, just remember to forward 113 TCP rather than 10052 UDP.
__________________
With our extreme gelatinous apology,
We beg to inform your Imperial Majesty,
Unto whom be dominion and power and glory,
There still remains that strange precipitate
Which has the quality to resist
Our oldest and most trusted catalyst.
It is a substance we cannot cremate
By temperatures known to our Laboratory.

~ E.J. Pratt
 
DoomFrost

JCF Member

Joined: Sep 2005

Posts: 24

DoomFrost is doing well so far

Sep 13, 2005, 06:56 PM
DoomFrost is offline
Reply With Quote
Sorry for my lack of network knowledge, but how do I actually get my computer to forward port 113? Where would I go in the host computer to allow access?

Would I go into Windows Firewall and go the exceptions tab and manually type in the ports? Or would I have to go somewhere else to open them?


EDIT: I never really thought of this until now, but could it be that my trial with MIRC is expired is the reason why it's preventing me from using Identd?
__________________

Last edited by DoomFrost; Sep 13, 2005 at 07:07 PM.
White Rabbit White Rabbit's Avatar

JCF Member

Joined: Aug 2001

Posts: 4,478

White Rabbit is doing well so far

Sep 15, 2005, 08:57 AM
White Rabbit is offline
Reply With Quote
About your questions, I've no idea. but try using an irc web client: www.jj2.info
Stijn Stijn's Avatar

Administrator

Joined: Mar 2001

Posts: 6,964

Stijn is a splendid one to beholdStijn is a splendid one to beholdStijn is a splendid one to beholdStijn is a splendid one to beholdStijn is a splendid one to beholdStijn is a splendid one to beholdStijn is a splendid one to behold

Sep 15, 2005, 09:10 AM
Stijn is offline
Reply With Quote
Code:
-se.quakenet.org- *** Looking up your hostname
-
-se.quakenet.org- *** Checking Ident
-
-se.quakenet.org- *** Found your hostname
-
-se.quakenet.org- *** No ident response
You're seeing that?
Torkell Torkell's Avatar

Stealth Admin

Joined: Jul 2004

Posts: 2,153

Torkell is a forum legendTorkell is a forum legendTorkell is a forum legend

Sep 15, 2005, 12:11 PM
Torkell is offline
Reply With Quote
You may also find you have ident problems if the ident port is 'stealthed'. Since stealthed ports do not send any response, anything trying to use them will keep trying (sometimes for several minutes). Changing the port to non-stealthed closed will sort that.

(I know that's not your problem, but it's a useful snippet of information for others with similar problems).
__________________
-- Torkell



Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

All times are GMT -8. The time now is 08:32 PM.