Register FAQ Search Today's Posts Mark Forums Read
Go Back   JazzJackrabbit Community Forums » Open Forums » General Jazz Jackrabbit Talk

Help! Jazz keeps going left...

Olsen Olsen's Avatar

JCF Member

Joined: May 2004

Posts: 1,368

Olsen is doing well so far

Jul 2, 2007, 05:53 AM
Olsen is offline
Reply With Quote
Help! Jazz keeps going left...

...without me pressing any button on the keyboard. I tried plugging the keyboard out, but that didn't help at all. I tried changing from 1.23+ to the normal JJ2 exe file, but that didn't work either. It's only Jazz 2 which has this problem, no other game on my computer has the same problem.

Help?

It seems it thinks the buttons up and left are being pressed...
__________________
some kind of nature
Dermo Dermo's Avatar

JCF Member

Joined: Jun 2005

Posts: 1,743

Dermo should make better posts

Jul 2, 2007, 10:01 AM
Dermo is offline
Reply With Quote
Change your control settings. Go into options and stuff. Maybe something just got rearranged in your control settings somehow.
__________________
Yes, I am, in fact, ALWAYS the one to blame for everything. And none of your are full of yourself. Good job.

Do you like Stijn? Take my poll!




Windows is not a virus. A virus is small and efficient...

Note to Stijn: how am i even getting away with this
Olsen Olsen's Avatar

JCF Member

Joined: May 2004

Posts: 1,368

Olsen is doing well so far

Jul 2, 2007, 10:35 AM
Olsen is offline
Reply With Quote
Quote:
Originally Posted by Drmoo View Post
Change your control settings. Go into options and stuff. Maybe something just got rearranged in your control settings somehow.
I would, if I could. That was the first thing I tried to do, but since the game thinks the up button is pressed, I can not coordinate in the menus, the selection just keeps scrolling and scrolling, holding down won't help either.

I don't even think it's a problem with my keyboard, since plugging the keyboard OUT didn't help even.
__________________
some kind of nature
Neobeo

JCF Member

Joined: Sep 2002

Posts: 409

Neobeo is an asset to this forumNeobeo is an asset to this forum

Jul 2, 2007, 10:37 AM
Neobeo is offline
Reply With Quote
The one time I had this problem it was because my joystick wasn't calibrated properly and was pointing "up".
__________________
<TABLE border=1><TR><TD>Facts:
Jazz Sprite Dynamite (JSD)
Tileset Extractor
Neobeo's Firetruck

</TD><TD>Myths:
Jazz Creation Station Plus (JCS+) - 10%
Coming soon - a dedicated server! - 25%
Jazz Sprite Dynamite v2 (JSDv2) - 2%
Another generic single-player level - 0%
</TD></TR></TABLE>
Olsen Olsen's Avatar

JCF Member

Joined: May 2004

Posts: 1,368

Olsen is doing well so far

Jul 2, 2007, 11:19 AM
Olsen is offline
Reply With Quote
Okay, well, no gamepad or joystick is connected to my computer, so that can't be the case then...
__________________
some kind of nature
Jerrythabest Jerrythabest's Avatar

JCF Member

Joined: Apr 2005

Posts: 2,602

Jerrythabest is a forum legendJerrythabest is a forum legendJerrythabest is a forum legend

Jul 2, 2007, 12:05 PM
Jerrythabest is offline
Reply With Quote
I have this kind of problems for ages too. Whenever anyone saw me rejoining or rehosting with reason "JJ2 locked up" it's Jazz (Spaz, in my case) running left. For me, when this happens, I always pressed the down key. I don't have any joysticks or gamepads connected either and Jazz is the only program with this problem. For me, Jazz locks up entirely, I can't use the F-keys JJ2 uses, character controls, the Escape key, just nothing. I just keep running left until I die and then I just stand still.
__________________
Dermo Dermo's Avatar

JCF Member

Joined: Jun 2005

Posts: 1,743

Dermo should make better posts

Jul 2, 2007, 12:16 PM
Dermo is offline
Reply With Quote
When I had this problem I uninstalled and reinstalled jazz jackrabbit 2. Make sure to use the uninstall assister.
__________________
Yes, I am, in fact, ALWAYS the one to blame for everything. And none of your are full of yourself. Good job.

Do you like Stijn? Take my poll!




Windows is not a virus. A virus is small and efficient...

Note to Stijn: how am i even getting away with this
Xobim Xobim's Avatar

JCF Member

Joined: May 2005

Posts: 2,454

Xobim is doing well so far

Jul 3, 2007, 01:14 AM
Xobim is offline
Reply With Quote
I've had a problem with the escape button too. Restarting my pc solved the problem. I'm not sure, but I've seen the "going left"-problem in Commander Keen too. Restarting your pc should solve it...
Dermo Dermo's Avatar

JCF Member

Joined: Jun 2005

Posts: 1,743

Dermo should make better posts

Jul 3, 2007, 07:02 AM
Dermo is offline
Reply With Quote
I had the problem in heretic once when I had windows 98. I was like 6 so I just asked my dad for help. He just reinstalled it for me (that was before I had the knowledge I have now i can manipulate DOS better than windows now :P )
__________________
Yes, I am, in fact, ALWAYS the one to blame for everything. And none of your are full of yourself. Good job.

Do you like Stijn? Take my poll!




Windows is not a virus. A virus is small and efficient...

Note to Stijn: how am i even getting away with this
Jerrythabest Jerrythabest's Avatar

JCF Member

Joined: Apr 2005

Posts: 2,602

Jerrythabest is a forum legendJerrythabest is a forum legendJerrythabest is a forum legend

Jul 3, 2007, 11:41 AM
Jerrythabest is offline
Reply With Quote
Well, closing and restarting JJ2 fixes it for me, it's just annoying that you'll have to rehost/rejoin games, esspecially if you're hosting or if it's a private game.
__________________
TheKax

JCF Member

Joined: Jan 2007

Posts: 82

TheKax is doing well so far

Jul 4, 2007, 06:51 AM
TheKax is offline
Reply With Quote
It's the curse!

Darn, you have a cursed rabbit in your PC!
No, sorry, didn't mean to laugh, sad that your rbbit has gone crazy.
__________________
Prove me wrong if I am wrong. -TheKax

It seem JCF administration got a move on since my name got "finally" changed. But hey thanks guys out there.

Making kind of a tribute to Foo races + research on the subject... (It's going better now that we have finally foo races uploaded ==> HERE.)
Progress: ▄▀▄▀▄▀▄▀▄ 10% or so...
And also randomly here and there hosting the original Team Foo races!


"Your reputation on this post is Somewhat Positive."
Falcury

JCF Member

Joined: Nov 2005

Posts: 65

Falcury is doing well so far

Jul 4, 2007, 08:12 AM
Falcury is offline
Reply With Quote
Whenever this happened to me, I think I fixed it simply by pushing and releasing 'left' if Jazz kept going to the left.
Jerrythabest Jerrythabest's Avatar

JCF Member

Joined: Apr 2005

Posts: 2,602

Jerrythabest is a forum legendJerrythabest is a forum legendJerrythabest is a forum legend

Jul 4, 2007, 09:34 AM
Jerrythabest is offline
Reply With Quote
That hasn't worked for me (otherwise I wouldn't be posting in this thread either)...
__________________
Valco Valco's Avatar

JCF Member

Joined: Jun 2006

Posts: 516

Valco is notorious for his worthless posts

Jul 10, 2007, 07:44 AM
Valco is offline
Reply With Quote
Perhaps you scared Jazz? He's probably trying to escape your wrath or something.
__________________
GENERATION 23: The first time you see this, copy it into your sig on any forum and add 1 to the generation. Social experiment.


The ultimate race experience
Coming soon to Jazz2Online
Speeza Speeza's Avatar

JCF Member

Joined: Jan 2006

Posts: 1,628

Speeza is an asset to this forumSpeeza is an asset to this forum

Jul 10, 2007, 08:48 AM
Speeza is offline
Reply With Quote
Quote:
Originally Posted by Drmoo View Post
I had the problem in heretic once when I had windows 98. I was like 6 so I just asked my dad for help. He just reinstalled it for me (that was before I had the knowledge I have now i can manipulate DOS better than windows now :P )

ADMIT IT THAT WAS TODAY!!!
__________________
You like it when I talk bad about myself don't you cooba <3
The only true wisdom is in knowing you know nothing.

Your friendly JCF Hillybilly
DavidkazBest poster of 2010 ! [GpW]
FreeFull FreeFull's Avatar

JCF Member

Joined: Sep 2006

Posts: 536

FreeFull is doing well so far

Jul 10, 2007, 08:53 AM
FreeFull is offline
Reply With Quote
I've could do this when I was 4.
__________________
I am.
StNick

JCF Member

Joined: Apr 2007

Posts: 26

StNick is doing well so far

Jul 10, 2007, 08:58 AM
StNick is offline
Reply With Quote
Quote:
Originally Posted by FreeFull View Post
I've could do this when I was 4.
Cool.
__________________
J2nsm
Olsen Olsen's Avatar

JCF Member

Joined: May 2004

Posts: 1,368

Olsen is doing well so far

Jul 18, 2007, 12:21 PM
Olsen is offline
Reply With Quote
Uninstalling didn't do anything to help the problem. ;_;
__________________
some kind of nature
Odin Odin's Avatar

Banned

Joined: Dec 2003

Posts: 3,776

Odin is doing well so far

Jul 18, 2007, 01:03 PM
Odin is offline
Reply With Quote
Do you have a gamepad plugged in? If so, increase the deadzone (area in which the analog stick can lie without sending data) on your analog sticks.
Olsen Olsen's Avatar

JCF Member

Joined: May 2004

Posts: 1,368

Olsen is doing well so far

Jul 18, 2007, 01:40 PM
Olsen is offline
Reply With Quote
Nope, I don't. I have a gamepad here, but it aint plugged in. (Yeah, I checked. Several times.)

So, uh, I removed PPJoy, perhaps it disturbed it or something, but that didn't help. (Yeah, I restarted my computer just to be sure.)

Hmm, I just played Thief - Deadly Shadows, and I realised there is some joystick (-)... but I can't figure out what. I plugged in my gamepad, recalibrated it (didn't help) then reset it (didn't help). And it doesn't help to plug it out either... gotta try the bluetooth thingie used to connect the wiimote to the pc, see if it's gonna help.

What, the heck... It was the bluetooth dongle doing something... I don't know why, but it interferes with some kind of virtual joystick.

Weird.
__________________
some kind of nature

Last edited by Olsen; Jul 18, 2007 at 02:59 PM.
Odin Odin's Avatar

Banned

Joined: Dec 2003

Posts: 3,776

Odin is doing well so far

Jul 19, 2007, 04:18 AM
Odin is offline
Reply With Quote
Wait, so the problem's solved?
Olsen Olsen's Avatar

JCF Member

Joined: May 2004

Posts: 1,368

Olsen is doing well so far

Jul 19, 2007, 04:38 AM
Olsen is offline
Reply With Quote
Quote:
Originally Posted by Odin View Post
Wait, so the problem's solved?
Well, when I plug out my Bluetooth adapter, yes. When I plug it back in, no.
__________________
some kind of nature
FreeFull FreeFull's Avatar

JCF Member

Joined: Sep 2006

Posts: 536

FreeFull is doing well so far

Jul 19, 2007, 08:17 AM
FreeFull is offline
Reply With Quote
Maybe its the position of Wiimote? (Playing Jazz 2 with Wiimote?)
__________________
I am.
Odin Odin's Avatar

Banned

Joined: Dec 2003

Posts: 3,776

Odin is doing well so far

Jul 19, 2007, 08:29 AM
Odin is offline
Reply With Quote
Quote:
Originally Posted by FreeFull View Post
Maybe its the position of Wiimote? (Playing Jazz 2 with Wiimote?)
Hmm... is the wiimote off?
Olsen Olsen's Avatar

JCF Member

Joined: May 2004

Posts: 1,368

Olsen is doing well so far

Jul 19, 2007, 08:42 AM
Olsen is offline
Reply With Quote
Quote:
Originally Posted by Odin View Post
Hmm... is the wiimote off?
Yes, and now I even removed the connection shortcut to the wiimote, if it was somehow causing trouble.

And, it was. Just stopping "My Bluetooth Places" fixed the problem. Hmm.

Okay, Bluetooth connection is still going but turning off the connection to my wiimote fixed the problem...

Also, I think it was because some time ago I ran a script using GlovePIE which let the wiimote simulate steering and acceleration and braking and all that, by turning movement into buttonpresses, and I played Flatout 2 using that when the game suddenly crashed, while turning left and accelerating which would mean pressing left and up...

Strangely, this is only affecting me in games. Doesn't happen anywhere else.
__________________
some kind of nature

Last edited by Olsen; Jul 19, 2007 at 08:54 AM.
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

All times are GMT -8. The time now is 08:07 PM.