Register FAQ Search Today's Posts Mark Forums Read
Go Back   JazzJackrabbit Community Forums » Open Forums » JCS & Scripting

Issue w/ tileset compiling

Mike_1990

JCF Member

Joined: Mar 2012

Posts: 15

Mike_1990 is doing well so far

Nov 20, 2017, 11:39 AM
Mike_1990 is offline
Reply With Quote
Issue w/ tileset compiling

Recently I've tried to tweak some jj2 original tilesets for my levels but I have problem with creating masks for the tileset. As I never did it before I've tried to do it by following walkthrough on DTR, made sure about the no. of colors and all that and swapped transparents so that they are the first entries on a palette. Tileset compiles ok but no matter what, masks just WON'T F** SHOW (aargh, so mad). Am I missing something here?
Seren Seren's Avatar

JCF Member

Joined: Feb 2010

Posts: 802

Seren is a name known to allSeren is a name known to allSeren is a name known to allSeren is a name known to allSeren is a name known to allSeren is a name known to all

Nov 20, 2017, 02:11 PM
Seren is offline
Reply With Quote
If you use Tileset Extractor, the mask picture it produces uses two palette indexes, 0 and 1, both of which are treated by JCS as transparent (i.e. non-solid in case of mask) when building a tileset. You will have to modify the picture to use a different palette entry for solid parts. Depending on your image editor of choice, the easiest way to do it may be to apply a palette that contains the transparency purple at index 0, black at index 16, and white everywhere else, while maintaining nearest color matching. Although if your image editor supports palette-based color replacement, that should be simpler.

I haven't done this for a while so if that fails, you may also want to look into replacing color #000000 (black) with another color. I can't remember right now if JCS has any special treatment of black.
__________________

I am an official JJ2+ programmer and this has been an official JJ2+ statement.
Mike_1990

JCF Member

Joined: Mar 2012

Posts: 15

Mike_1990 is doing well so far

Nov 21, 2017, 06:14 AM
Mike_1990 is offline
Reply With Quote
Alright, it took ages but I finally made it work. Basically the main problem was with pallet generated by tileset extractor. The colors were right but it swapped jazz blue and black. If black isn't on #0 and blue on #1 it won't register them as transparent. So I just switched them and now it works just fine. Thanks for advice anyway. At least I'll never have to go through this hell again.
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

All times are GMT -8. The time now is 10:59 PM.